资源下载 - 从此开始!

下载我_精品源码软件教程资源网

您的位置:主页 > 网络编程 > 正文

易语言注册自定义协议Register protocol

2018-12-01 11:30 来源:互联网 编辑:admin

Register protocol

tencent:// thunder:// 是 腾讯 和 迅雷 的协议,即页面上或地址栏里的链接只要输入带有 tencent://… 的协议,就会自动调用一个已写好的程序执行该协议的操作。 或者是打开页面,迅雷的是下载资源的链接。

通过微软的说明,知道这是Register protocol,对于 Windows、Linux 和 OS X 操作系统都可以注册这样的协议。比如说Windows,其实只需写入注册表,即可实现协议与执行程序的关联。

DLL命令表

.版本 2
.DLL命令 RegCreateKey, 逻辑型, "Advapi32.dll", "RegCreateKeyA", 公开
 .参数 hKey, 整数型
 .参数 lpSubKey, 文本型
 .参数 phkResult, 整数型, 传址
.DLL命令 RegCloseKey, , "Advapi32.dll", "RegCloseKey", 公开
 .参数 hKey, 整数型
.DLL命令 RegSetKeyValue, 逻辑型, "Advapi32.dll", "RegSetValueExA", 公开
 .参数 hKey, 整数型
 .参数 lpSubKey, 文本型
 .参数 lpValueName, 文本型
 .参数 dwType, 整数型
 .参数 lpData, 文本型
 .参数 cbData, 整数型
.DLL命令 sprintf, 整数型, "msvcrt.dll", "@sprintf"
 .参数 s, 文本型, 传址
 .参数 foramt, 文本型
 .参数 arg, 文本型
.DLL命令 GetCommandLine, 文本型, "kernel32.dll", "GetCommandLineA", 公开

常量数据表

.版本 2
.常量 HKEY_CLASSES_ROOT, "2147483648"
.常量 REG_SZ, "1"

注册自定义协议Register protocol

.版本 2
.程序集 程序集1
.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
.局部变量 pszArgv, 文本型, , "0"
.局部变量 szExePath, 文本型
.局部变量 i, 整数型
.局部变量 Schemes, 文本型
标准输出 (, “Windows 注册自定义协议演示:”, #换行符)
取命令行 (pszArgv)
.如果真 (取数组成员数 (pszArgv) ≥ 1) ' 如果启动参数小于1,那说明并非由协议启动
 .计次循环首 (取数组成员数 (pszArgv), i)
  .如果真 (取文本左边 (到小写 (pszArgv [i]), 6) = “eyuyan:”)
   Schemes = 取文本右边 (pszArgv [i], 取文本长度 (pszArgv [i]) - 8) ' 协议数据
   标准输出 (, “收到协议数据: ”, Schemes, #换行符)
   ' 在这里就可以处理接收到的协议数据了
   标准输出 (, “按回车键结束程序!”, #换行符)
   标准输入 ()
   返回 (0)
  .如果真结束
 .计次循环尾 ()
.如果真结束
标准输出 (, “注册协议头: Ayana ”, #换行符, “在地址栏或者浏览器中输入: Ayana:hello%20world ,将会触发接收程序!”, #换行符)
szExePath = 取运行目录 () + “” + 取执行文件名 ()
登录协议 (“eyuyan”, szExePath + “,0”, szExePath)
标准输出 (, “按回车键结束程序!”, #换行符)
标准输入 ()
返回 (0)
.子程序 登录协议, , 公开, 注册自定义windows 协议
.参数 协议头, 文本型, , 协议头: 比如 schemes
.参数 图标文件, 文本型, , 图标文件
.参数 协议接收程序, 文本型, , 协议接收程序
.局部变量 根HKEY, 整数型, , , 根HKEY
.局部变量 文本, 文本型
.局部变量 结果, 文本型
文本 = 取空白文本 (60)
sprintf (文本, “%sProtocol”, 协议头)
RegCreateKey (#HKEY_CLASSES_ROOT, 协议头, 根HKEY)
RegSetKeyValue (#HKEY_CLASSES_ROOT, 协议头, “”, #REG_SZ, 文本, 取文本长度 (文本))
RegSetKeyValue (#HKEY_CLASSES_ROOT, 协议头, “URL Protocol”, #REG_SZ, 协议接收程序, 取文本长度 (协议接收程序))
RegSetKeyValue (根HKEY, “DefaultIcon”, “”, #REG_SZ, 图标文件, 取文本长度 (图标文件))
RegSetKeyValue (根HKEY, “shell”, “”, #REG_SZ, “”, 0)
RegSetKeyValue (根HKEY, “shellopen”, “”, #REG_SZ, “”, 0)
结果 = 协议接收程序 + “ ” + #引号 + “%1” + #引号
RegSetKeyValue (根HKEY, “shellopencommand”, “”, #REG_SZ, 结果, 取文本长度 (结果))
RegCloseKey (根HKEY)

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值.

打赏一下,我们会为大家提供更多优质资源!

相关文章,95%的人会看!{有内幕、有真相...}

看过本文的人还看过

关闭

微信扫一扫

站长微信账号