正文 主页 > 站长学院 > Cms教程 >

如何解决升级到WordPress 5.5后导致js报错和网站功能不正常

下载我资源网

也就是说,有些主题或插件使用了比较老旧的jQuery函数,以前一直都采用jQuery Migrate1.x做兼容处理的,但是现在WordPress 5.5+ 默认禁用了这个兼容库,所以就出现问题了。


对于开发者来说,应该尽快更新自己的产品代码,尽可能使用新的jQuery函数。解除对jQuery Migrate1.x的依赖。开发者指南

对于大多数的普通用户来说,肯定是无法去自己修改代码做兼容处理的,怎么办?

其实WordPress官方团队早就想到了这个问题,专门开发了一个小插件 Enable jQuery Migrate Helper,只需要安装和启用插件,就可以继续加载 jQuery Migrate1.x,让你的网站避免出现js错误。

不过,建议普通用户可以联系一下主题和插件作者,提醒他们更新代码,这样才是最好的做法。

-- 展开阅读全文 --