正文 主页 > 站长学院 > 服务器 >

linux系统虚拟主机开启支持Swoole Loader扩展的方法

下载我资源网

特别说明:只是安装支持Swoole扩展,主机并没有安装服务端。目前支持版本php5.4-php7.2。

1、登陆主机控制面板,找到【远程文件下载】这个功能。

image.png

2、远程下载文件填写https://www.xiazaiwo.net/uploads/21/0G13U5P-1.jpg 下载保存的路径填写/others/

或者从脚本之家下载

image.png

3、点击控制面板【php版本】,选择php5.3或以上版本,示例选择的是php5.5版本(注意:php5.2版本不能编辑php.ini,所以要选择以上版本)。

image.png

4、点击控制面板【文件管理】,打开进入others目录,鼠标放到刚才远程下载的压缩包上,点击解压按钮。解压后的文件名中数字对应的就是php版本,比如swoole_loader56.so 就是php5.6版本的扩展文件。

image.png

5、点击修改php.ini文件,复制当前路径,在php.ini底部最后一行加 extension=/home/xxxxxxxxxx/others/swoole_loader55.so(注意实际路径和具体版本),如下面图例所示。

image.png

6、进入wwwroot目录,创建一个x.php文件,打开编辑x.php,在里面输入<?phpinfo()?>保存,然后访问 http://自己的网站域名/x.php  搜索swoole,能找到就说明安装成功,如果找不到,请检查下操作步骤或者提交工单。

image.png

扩展冲突

注意: 请关闭xdebug,ioncube loader,zend guard loader等影响PHP底层行为的扩展。

如php.ini中注释:

;zend_extension=ioncube.so

PHP安装Swoole Loader扩展教程,适用于Windows和Linux

看到百度很多安装扩展还需要下载Cygwin的,所以特别推出这个教程说明一下,PHP安装Swoole Loader扩展是不需要安装Cygwin,看着网络中充斥着很多不负责任的安装教程顿时觉得有些可笑。或许他们只是为了发布文章而发布文章的,又或许只是为了SEO而发布文章的。

在安装Swoole Loader扩展前请先确认以下信息。

操作系统 :Windows NT AMD64
PHP版本 :7.2.22
PHP运行环境 :cgi-fcgiPHP
配置文件 :C:\BtSoft\php\72\php.iniPHP
扩展安装目录 :ext
PHP是否线程安全 :非线程安全

1、下载Swoole Loader扩展安装包

下载压缩包,然后找到对应你系统的 Swoole Loader扩展文件解压出来

下载地址:https://pecl.php.net/package/swoole

为了方便下载提供一个国内地址:https://zhiniaoyun.lanzous.com/ibfobgh

2、安装Swoole Loader

将刚才解压出来的Swoole Loader扩展文件(swoole_loader版本号.dll或swoole_loader版本号.so)上传到当前PHP的扩展安装目录中:ext

3、修改php.ini配置(如已修改配置,请忽略此步骤,不必重复添加)

编辑此PHP配置文件:C:\BtSoft\php\72\php.ini,在此文件底部结尾处加入如下配置

extension=刚才上传的文件名.dll

注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致(例如:extension=swoole_loader72.dll)

4、重启服务

重启或重载PHP配置

到此这篇关于linux系统虚拟主机开启支持Swoole Loader扩展的方法的文章就介绍到这了,更多相关linux Swoole Loader扩展内容请搜索脚本之家以前的文章或继续浏览下面的相关文章希望大家以后多多支持脚本之家!

-- 展开阅读全文 --